home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / sys-fs / xfsdump-2.2.25 / xfsdump-2.2.25.ebuild < prev   
Text File  |  2006-01-09  |  1KB  |  55 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-2.2.25.ebuild,v 1.6 2005/07/10 19:14:21 agriffis Exp $
  4.  
  5. inherit eutils
  6.  
  7. DESCRIPTION="xfs dump/restore utilities"
  8. HOMEPAGE="http://oss.sgi.com/projects/xfs"
  9. SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
  10.  
  11. LICENSE="LGPL-2.1"
  12. SLOT="0"
  13. KEYWORDS="alpha amd64 ia64 ~mips ppc -sparc x86"
  14. IUSE="debug"
  15.  
  16. DEPEND="sys-fs/e2fsprogs
  17.     sys-fs/xfsprogs
  18.     sys-apps/dmapi
  19.     >=sys-apps/attr-2.4.19"
  20.  
  21. src_unpack() {
  22.     unpack ${A}
  23.     cd ${S}
  24.     sed -i \
  25.         -e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
  26.         -e '/^GCFLAGS/s:-O1::' \
  27.         include/builddefs.in \
  28.         || die
  29. }
  30.  
  31. src_compile() {
  32.     if use debug; then
  33.         export DEBUG=-DDEBUG
  34.     else
  35.         export DEBUG=-DNDEBUG
  36.     fi
  37.     export OPTIMIZER="${CFLAGS}"
  38.  
  39.     # Some archs need the PLATFORM var unset
  40.     unset PLATFORM
  41.  
  42.     econf \
  43.         --libdir=/$(get_libdir) \
  44.         --libexecdir=/usr/$(get_libdir) \
  45.         --sbindir=/sbin \
  46.         || die
  47.     emake || die
  48. }
  49.  
  50. src_install() {
  51.     make DIST_ROOT=${D} install || die
  52.     dosym /sbin/xfsrestore /usr/bin/xfsrestore
  53.     dosym /sbin/xfsdump /usr/bin/xfsdump
  54. }
  55.